Cichlid Fish Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
30 gal
Nitrate 0, nitrite 0, hardness 150, chlorine 0, alkalinity 0, pH 6.0
Temp 75
I turn over 3 gal water per week, and tap water is pH 7.0 with excellent quality so I just age the water a week before using.
They eat Hikari cichlid gold.

I have a sick tank. This is the third time these symptoms have shown up. I used Rid Ich because I don’t know what else to use. I couldn’t find any photos of sick fish that really look like this. I have had aquariums for years and years, and never have problems, so this is befuddling to me. This tank is quite old, I used to have guppies in it. These Convicts are second and third generation from the ones I have upstairs in another tank- and have no problems in that tank at all. When I have treated it with Rid Ich, after about a week, the symptoms disappear. But it was just about a month ago the second time I treated, and here we go again. So obviously there's somethig going on that the Rid Ich isn't really eliminating.

I tried to get some still pics but they were too blurry. So I posted a video to YouTube. Just got the message that I have to post one post before adding urls, so will respond to myself with the link.
 

·
Registered
Joined
·
181 Posts
You say you have a sick tank but what exactly are the symptoms?.

Without knowing symptoms, the only thing that sticks out is your nitrate should never be zero, and less importantly your ph is a touch low but I doubt the ph is your problem as long as its consistently 6.0. Also are you sure your alkalinity is zero? THat would tell me your ph isn't stable which might be the problem. Your ph shouldn't fluctuate more then 0.3 in a 24 hour period so if it is than that could be causing stress on your fish.

Not sure what the problem is but I hope this helps.
 
1 - 3 of 3 Posts
Top