Cichlid Fish Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter · #1 ·
I am having problems with my XP3. Air keeps getting in the filter, don't know where. I will list the problems in order of occurrence.

-Upon priming, impeller chops through air pockets, causing a release of air bubbles from spraybar.
-Filter is very noisy (grinding and water trickling.
-I unplug filter and plug back in until noise it at a minimum.
-Water level in canister doesn't reach top upon priming, so I manually raise it by unclipping two clips.
-About an hour later, the water level is back down and the filter is noisy again. Trickling and some grinding can be heard within the filter.
-Water trickling noise can be heard IN the actual intake tube, at the top where the cap is and somewhat in the middle of the tube.

What's going on that is causing my filter to do this? It is really bothering me. Thanks.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #5 ·
Thanks, I will try that at my next PWC. One thing I just noticed, is that when plugging in the filter, the actual clear plastic part of the canister (the canister itself) literally gets squeezed in. I had my finger where the motor portion meets the clear plastic, and I felt it move inward when I plugged it in. When I unplug it, it releases. It doesn't happen to the front and rear portion, but only the sides. Is this normal? I never saw this happen before.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #6 ·
Checked everything, tightened everything...air is still getting in and splurting out from the spraybar. I really have no idea where air could be getting in from.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #9 ·
What will I do with all of my media if and when I send this one out for replacement? That's the only thing I am worried about, because I don't want to lose all of this seeded material.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #13 ·
gordonrp said:
Marconis said:
Checked everything, tightened everything...air is still getting in and splurting out from the spraybar. I really have no idea where air could be getting in from.
any cracks in the intake tubing?
Not that I can see. I'll have to take a look at it tomorrow morning.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top