Cichlid Fish Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter · #1 ·
Ok *** had a tank set up for about a year and a half. Part of the original gang are 6 petricola catfish who have always been healthy and active. About a couple weeks ago I noticed something on the underside of 2 of the 6 cats. They still eat fine, play and swim around, and dont show any signs of being down. There is not a single spot on another fish in the tank which includes cyps (adults+fry), paracyps, calvus, and tetras.
pH- 8.0-8.2
kH-15
ammonia and nitrites-0
nitrates-40 ( hard to tell exactly since 20-80 all look alike on the API test kits

I have a couple pics below. My dilemma is I am not sure if I want to add them back to the tank in case they end up being diseased and spreading it to my other fish. What should I do?



 

·
Registered
Joined
·
310 Posts
Discussion Starter · #3 ·
The substrate is half black sand and half eco-complete for plants wis is a little rougher. They were with all sand for the first year+ I added the eco-complete a few months ago. I see them flashing off and of all the time when they chase each other it concerned me at first, afraid it might be a parasite, but theyve done it since I got them a year and a half ago and theyve grown and been healthy since.
Thats what it looks like to me, gigantic scrapes. No fuzzies or redness or growths just missing skin. IDK what to do about it though and am afraid it will get infected and spread through the tank
 

·
Registered
Joined
·
310 Posts
Discussion Starter · #5 ·
its funny you say that because that was my first thought. They love swimming inside the innertube of the heater which has been on a lot lately due to the extreme cold. so what do i do add stress coat or prime and wait for it to heal?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top