Cichlid Fish Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter · #1 ·
I have a 125g African set up for 2 months, cycled and lightly stocked. Water tests are all fine, temp 79, ph 8.2, nitrates 10. Weekly water changes, over filtered, etc.

Fish have been scratching themselves for a few weeks, a little at first but now it seems more than a little too much and I'm thinking parasites. There are no white spots (ick) and I don't see anything else on them. Is there anything else I should be looking for?

I was thinking of getting a UV sterilizer at lunch time, if I can find one. Will a UV remove existing parasites? Is this the best course or should I look to do something else first?
 

·
Registered
Joined
·
18,306 Posts
A UV sterilizer is only going to be effective against free swimming parasites. It isn't going to do much for gill flukes, or anything within or attached to the body of the fish.

How often are they flashing? Some flashing is normal, especially following a water change. Is the same fish flashing over and over again?

Is the flashing focused in the gill area? Any redness around the gills?

Any fin deterioration?
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #3 ·
It seems to be happening more or different fish each time. no red gills but they do rub themselves against the sand in the gill area. I did a water change last night but it seems to be all the time.

Again, I don't see anything on the fish, could it be internal?
 

·
Registered
Joined
·
18,306 Posts
It could be gill flukes, but without seeing the fish and observing their behaviour, it's hard to say.

You could pick up a med for gill flukes and give it a try, but keep in mind that they can be quite difficult to eradicate, so you may need to treat longer than the package instructions advise. Squeeze in all the water changes that you can, too.
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #5 ·
Thanks, what meds do you think? I'll go at lunch to see what, if any, they have.
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #6 ·
Just got back from LFS with Jungle Anti-parasite food & API Fluke-tabs.
I'll start treatment tonight.
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #7 ·
Well, 9 months later and my fish are showing the same symptoms again. The meds I used last time worked(?)
but the same thing is happening again. Should I use the same meds or is there anything better to try.
I'm not sure they had gill flukes but the meds did seem to work.
 
1 - 7 of 7 Posts
Top