Cichlid Fish Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
What you get for the money seems too good to be true. I've read a lot bad things about some of their older models, but I don't think I have heard anything bad about the newer units.

The whole unit is under $100, including shipping.

Link to online retailer was removed. See policy here.
 

·
Registered
Joined
·
94 Posts
I've been using 2 20" cf odyssea fixtures for almost a year now with no problems. I have a 36" t5 also but haven't used it yet, other than to make sure it works. We ordered the cfs before I read all the horror stories- but so far they have been decent fixtures at a great price. My husband ordered them from ebay, don't know if the prices are better there than at aquabuys.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #3 ·
Little more expensive on Ebay actually. Plus they charge $20 for shipping, aquatraders has free shipping on this light.
 

·
Registered
Joined
·
1,118 Posts
where are the legs I had one and the legs are so cheap they broke on me three times order
extra sets, I made some good luck, I have a catlina lamb now from ebay not much more
but a lot better light made of aluim etc.
 

·
Registered
Joined
·
143 Posts
i use Odyssa lights and they have been great.... i fact i trust the traders for quite a few things... have not had a problem at all....
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #6 ·
I don't think I'm going to use the legs, I'm going to fabricate some brackets so that I can mount it under my canopy.
 

·
Registered
Joined
·
326 Posts
So far so good...The bulbs it ships with are not all that great. The 10k bulbs are okay...the actinic bulbs I did not like at all and never used them. I added a coral life 10k bulb and a zoo med 6500k bulb. I will probably get two more of the zoo med bulbs as they seem to be the best for the money. I plan on upgrading the ballast eventually with an icecap 660 but the stock ballasts are working fine. I am pleased with what I got for the money.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #8 ·
Well my light came in today, and one of my ballasts was broken :?

There is a small screw and a small washer loose inside the housing, I'm guessing they're to hold the circuit board down inside the housing. As a result of this, the circuit board was probably banging around and got damaged. Some little coil thing and what looks to be a heat sink in the back are not seated correctly on the circuit board. I sent them a message, let's see what their response is. I'm sure they will take care of it.

Other than that, I hooked it up and it *********, and that's with only two of the four lights working. I can only imagine what it will look like when I turn on the other 2 lights after they send me a new ballast.



 
1 - 8 of 8 Posts
Top