Cichlid Fish Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,657 Posts
Discussion Starter · #1 ·
Just the other day in another thread, I posted how I liked the C360 and it's been great so far on my 180g. Well today, I moved it literally 4 inches to one side to make room and shortly after that it started leaking. I took the top off, cleaned and inspected the O ring and put it back together. I ran good for 15 mins then started leaking worse. Anyone who has had one leak what was the solution? I was gonna try to lube the O ring with Vaseline or just end up buying another FX5.
 

·
Registered
Joined
·
1,657 Posts
Discussion Starter · #2 ·
Tried the vaseline on the O ring and it still leaked. I'm gonna call Marineland customer service tomorrow. I've delt with them in the past and they've been real good. Problem is I got the filter used with a package deal with my 180g, so I don't know how old it is. I can't lie because they ask for lot numbers etc... and will know how old it is. :lol:
 

·
Registered
Joined
·
1,657 Posts
Discussion Starter · #3 ·
Marineland sent me a new valve unit on top and so far so good. After calling and giving them the lot number, the filter was over 4 years old. They sent me the part with no questions asked. Thats pretty decent customer service for a 4 year old filter that I didn't even buy.
 

·
Registered
Joined
·
355 Posts
I've also recieved great customer service from them in the past. I had an impeller go bad on an old Penguin 330 that was 4 or 5 years old and they shipped me a new one no questions asked and it arrived pretty quickly also. I was pleased.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top