Cichlid Fish Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have not made a post here in so long I had to rejoin the site. I just mostly read and not had any problem with tanks in the past three years. My first tank was a mess thanks to this site got me on the right track.My problem is with the rocks,glass,fake plants and filter intake turning brown.
It's a 125 gallon 72x18x24 I keep the water at 80. Filters are ac110, Fluval 405,rena xp3 and two penguin 660 used for under substrate jets. There are close to 30 Malawi cichlid I feed once a day or every other day using nlc. A year ago I thought it was phosphate from my tap water. But none of my other tanks have the problem. At one time I had a 25lb peace of white taxes rock but would turn brown now I have it in my 75 and it stays bright white.the only other thing of is there over 125lbs limestone and other type of landscape rocks that I don't have in my other tanks. Would the larger rocks cause the algae?
 

·
Registered
Joined
·
56 Posts

·
Registered
Joined
·
572 Posts
No more algae would do the trick made by jungle
 

·
Registered
Joined
·
13 Posts
Hey Cave1 ...Two words "Bristlenose plecos" ! Had the same problem a few months back in my new tank. I have 10K lights and man the stuff took off! LPS said the only cure was to clean everything or turn the lights off till its gone?? What?? I have a 4 foot 90gal and I put 4 of these bad boys in there and in two nights it was GONE! I do see a piece of green stuff from time to time but you have to look fast because it won't be there the next time you come in the room !! Also a good reason to buy more fish ...they stay small too, a plus for me, don't care for the great biggun's..
 

·
Registered
Joined
·
572 Posts
Man I got to get me a few of those in my tank,I have a 150gl an I forgot about them .I may go buy some today about 4-5 of them.
ceb2 said:
Hey Cave1 ...Two words "Bristlenose plecos" ! Had the same problem a few months back in my new tank. I have 10K lights and man the stuff took off! LPS said the only cure was to clean everything or turn the lights off till its gone?? What?? I have a 4 foot 90gal and I put 4 of these bad boys in there and in two nights it was GONE! I do see a piece of green stuff from time to time but you have to look fast because it won't be there the next time you come in the room !! Also a good reason to buy more fish ...they stay small too, a plus for me, don't care for the great biggun's..
 

·
Registered
Joined
·
219 Posts
Another excellent option is Olive nerite snails. My 55g Lake Tang. tank was covered in brown algae. 10 O. nerites completely cleaned it in less than 2 weeks. Got them on Aquabid. My 2 bristlenoses keep my CA tan spotless.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top