Cichlid Fish Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
I got a second brand new Ehiem pro 600 canister for Christmas. I noticed a faint clicking noise audible from outside the cabinet right away and is driving me crazy. It is amplified by the hollow cabinet. I have disassembled, rinsed, inspected and reassembled several times and still hear the sound. Everything seems to be seated correctly. I am familiar with impeller rattle, this is not the same noise. Just a faint clicking as if a pebble were being tossed about inside.

I researched online only see impeller and leaking issues. After a very long hold time for Ehiem Customer Service, they said it would have to either be air bubbles trapped inside or the red float valve not seated making the noise. I shook gently to release any air bubbles. I also unplugged, made sure the valve is seated properly several times. Still makes the noise. I have an identical filter on the same tank I have had for over a year with no issues.

Since I have been made aware of the red float valve, I feel it is more than likely the problem. Has anyone else experienced this problem or know what to do about it? Should I return it?
 

·
Registered
Joined
·
1,040 Posts
Eheim makes a great filter and I think the best filter on the market, but they don't make a perfect filter. Consider replacing the red float valve. That part could have cam defective.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top