Cichlid Fish Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey,

On Saturday i brought a pair of Blockhead Cichlids. To my suprise on Monday i noticed they'd laid about 40 eggs and stuck them onto the back of a cave ornament.
Well today when i was cleaning the tank i noticed the eggs have gone, the parents seem very restless too. I thought it took a week for the eggs to hatch so isn't this abit early?
If anyone has any ideas as to what could have happened, please let me know. Thankies...

Mel x
 

·
Registered
Joined
·
803 Posts
probably eaten by the parents or someother fish in the tank. New parents will sometimes eat the eggs or if the eggs are bad/infertile, the parents will also eat them.
 

·
Registered
Joined
·
82 Posts
That almost five days since the spawn.. Depending upon temperature, substrate spawning cichlid eggs usually hatch in about 3 days.. Your nervous parents may be guarding some wigglers....
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I haven't noticed any fry, the female seems busy making a new 'home'. Their actually in a tank by themselves, so nothing else would eat them. Maybe the eggs were bad, or maybe it's just due to stress as i haven't had them for long.

Mel x
 

·
Registered
Joined
·
48 Posts
Hi Mel,

I noticed that you are from Suffolk, UK. There are quite a few cichlid fans in the East Anglia region, a lot of us use the forum at http://www.oddballexpress.co.uk/phpBB2/index.php and the BCA.
As for your blockheads, there is still hope for the fry, they may emerge in a few days. Cichlids often eat the eggs on the first attempt. Just keep an eye on the female as the male will be keen to spawn again and she won't be ready!
Good luck!
Simon
 
1 - 5 of 5 Posts
Top