General Aquaria Discussion • Algae in AC tank

For general fish and aquarium topics. Including catfish, aquatic plants, ponds, photography, etc.

Moderators: DJRansome, fmueller

Algae in AC tank

Postby sweetcheekz1130 » Thu Nov 17, 2016 9:01 pm

Hello, I've got an algae running amok in our 65 gal tank. I've got a magnum 350 filter and 13 baby (2yr old) Jack Dempsey's. All from the same parents (who are in our 150 gal). pH 7.8, nitrates and nitrites are 20-30 and no ammonia. We've done weekly water changes and stubbed the clay pots and hoses and filter. I've never seen anything like this. I've had AC's for a little over 18 years. Current tanks have been established for 8 years. Any suggestions would be greatly appreciated! I have video and pics but I'm not sure how to upload/share. It resembles blue hair algae somewhat. Thank you!
sweetcheekz1130
 
Joined: Thu Nov 17, 2016 8:36 pm
Location: USA

Share On:

Share on Facebook Facebook Share on Twitter Twitter

Re: Algae in AC tank

Postby DJRansome » Thu Nov 17, 2016 10:54 pm

Change the water to get nitrates to 10ppm. Hopefully that is a typo and nitrites are zero. What is your lighting?
125G Borleyi, Multipunctata
75G Demasoni, Msobo, Lucipinnis
75G Calvus, Similis, Petricola
User avatar
DJRansome
Global Moderator
 
Joined: Sat Oct 29, 2005 8:30 am
Location: Little Egg Harbor, NJ

Re: Algae in AC tank

Postby awanderingmoose » Fri Nov 18, 2016 9:18 am

Is the tank near a window where it's getting sunlight?
Why in the world are we here? Surely not to live in pain and fear!
awanderingmoose
 
Joined: Wed Aug 10, 2016 9:09 pm
Location: Way up north, eh


Return to General Aquaria Discussion

Who is online

Users browsing this forum: No registered users and 8 guests