South American Cichlids • Fungus?

Discussion regarding only South American Cichlid species. (Oscars, Geophagines, Discus, Apistogramma, Green Terrors, Angels, Severums, Pikes, etc.)

Moderators: notho2000, Iggy Newcastle

Fungus?

Postby scatterbolt » Mon Dec 09, 2019 8:19 am

Hello,

I am a new Oscar owner. My husband set up a 90 gallon for two male oscars (each about 9 inches long). We've had them for about two weeks. About 3 days ago, I noticed a faint white mark on one of them. The next day, it had grown to the size of a dime, with the whiteness concentrated around the edges. The original mark is now surrounded by smaller ones.

Has anyone seen this before? Can you advise as to the proper treatment? We have been fighting ammonia buildup, but check it several times daily and have been doing appropriate water changes and treatments to get it under control.
Attachments
IMG-9977.JPG
IMG-9975.JPG
scatterbolt
 
Joined: Mon Dec 09, 2019 8:09 am
Location: United States

Share On:

Share on Facebook Facebook Share on Twitter Twitter

Re: Fungus?

Postby Iggy Newcastle » Sat Dec 21, 2019 9:43 am

Sorry for the late reply... welcome to the forum.

First and foremost, as you've pointed out, you need to get your ammonia/water issues handled. Sounds like the fish were added to an uncycled tank. If that's the case, you're likely to have a nitrite spike. What are the current water parameters?

How does the oscar look now? Are the white marks fuzzy looking? It appears to me like abrasions, but difficult to tell from the photos.
User avatar
Iggy Newcastle
Moderator
 
Joined: Tue May 15, 2012 6:04 pm
Location: Chicagoland


Return to South American Cichlids

Who is online

Users browsing this forum: Google [Bot] and 3 guests