General African Cichlid Discussion • My water just doesn't seem clean enough

For general questions and issues. Post here if you are unsure of their origin or if you have questions about mixing.

Moderator: DJRansome

My water just doesn't seem clean enough

Postby Chelps03 » Mon May 14, 2012 6:32 pm

I have a aquaclear 110 in my 55 gal tank. I thought it was suppossed to be a pretty good filter but I seem to have to much debris in my tank. I thought about going to a canister filter like a fluval. Would one do the trick or two? Any thoughts or advice? Thanks
Chelps03
 
Joined: Thu Mar 08, 2012 9:47 pm
Location: Indiana

Share On:

Share on Facebook Facebook Share on Twitter Twitter

Re: My water just doesn't seem clean enough

Postby DJRansome » Mon May 14, 2012 8:08 pm

What type of debris is it? Unless it is fish feces, try to remove the source of the debris. Do you vacuum the substrate thoroughly every week? Do you have live plants that shed?
125G Aulonocara, Malawi Haps, Vics (trial), S Polli
75G Demasoni, Labs, Cyno hara, Met estherae, S Multipunctata
75G Calvus, Caudopunctatus, Cyp Kerenge, S Petricola
33G Neo omnicaeruleus; 33G Flameback Kisumu; 33G P nyererei Igombe; 33G Hap ruby green
User avatar
DJRansome
Global Moderator
 
Joined: Sat Oct 29, 2005 8:30 am
Location: Boonton Township, NJ

Re: My water just doesn't seem clean enough

Postby Chelps03 » Mon May 14, 2012 10:03 pm

Yes it is fish feces. Just particles floating makes my tank look unclean.
Chelps03
 
Joined: Thu Mar 08, 2012 9:47 pm
Location: Indiana

Re: My water just doesn't seem clean enough

Postby 13razorbackfan » Mon May 14, 2012 10:33 pm

Chelps03 wrote:Yes it is fish feces. Just particles floating makes my tank look unclean.

Is the poop not making it to the intake? My doesn't all the time either so I vacuum what I can when do water changes.

You can also add filter floss to help polish the water but be warned it has to be replaced often depending on the load.
User avatar
13razorbackfan
 
Joined: Wed Sep 28, 2011 12:19 am
Location: Arkansas

Re: My water just doesn't seem clean enough

Postby DJRansome » Tue May 15, 2012 6:46 am

A canister isn't going to filter out more particles than your Aqua Clear, so we need to look for another solution.

If you first clean the filter and then vacuum, then at that time there are no feces...is the water clean then?

How many/what size fish are in the tank?
125G Aulonocara, Malawi Haps, Vics (trial), S Polli
75G Demasoni, Labs, Cyno hara, Met estherae, S Multipunctata
75G Calvus, Caudopunctatus, Cyp Kerenge, S Petricola
33G Neo omnicaeruleus; 33G Flameback Kisumu; 33G P nyererei Igombe; 33G Hap ruby green
User avatar
DJRansome
Global Moderator
 
Joined: Sat Oct 29, 2005 8:30 am
Location: Boonton Township, NJ

Re: My water just doesn't seem clean enough

Postby AulonoKarl » Tue May 15, 2012 12:19 pm

I had this problem when I was running only one aquaclear filter on my 55 gallon. When I added the other, the circulation improved to where all of the debris started making it's way to the filters. I have an AC70 and AC110 on my 55 gallon and there are no dead spots. All debris finds the intakes relatively quickly. I would not only have one point of circulation on a 4 foot tank.
User avatar
AulonoKarl
 
Joined: Thu Mar 08, 2012 11:56 pm
Location: Kentucky

Re: My water just doesn't seem clean enough

Postby kenko » Tue May 15, 2012 12:49 pm

I would consider the fauna in the case of adding more filters/filtration, as some fish may feel stressed in highly circulated water...
Geo. Tapajos, D. Maculatus, Tetras: Emperor, Flame, Neon, Yellow, L129, Brown BNP, Cyath. Furcifer Ruziba, Dewindti, Callo. Melanostigma and Pleurospilus, Leleupi, Tretocephalus, Yellow Calvus, Afra Cobue, SRT Hongi, Syn. Lucipinnis, Euptera, Ocellifer
User avatar
kenko
 
Joined: Thu Jan 19, 2012 6:50 pm
Location: Schaumburg, IL

Re: My water just doesn't seem clean enough

Postby countryboy814 » Tue May 15, 2012 1:52 pm

AulonoKarl wrote:I had this problem when I was running only one aquaclear filter on my 55 gallon. When I added the other, the circulation improved to where all of the debris started making it's way to the filters. I have an AC70 and AC110 on my 55 gallon and there are no dead spots. All debris finds the intakes relatively quickly. I would not only have one point of circulation on a 4 foot tank.

Yes I agree. You need more circulation in a 4' tank. I have an aquatop cf-400 uv canister with the intake set low to the bottom of the tank and a penguin 350 with the intake set at mid level. Intakes are on opposite ends of the tank. The 350 creates a lot of surface agitation as does your AC110. I also have a power head rigged with a micron filter in tank.
User avatar
countryboy814
 
Joined: Sun Feb 19, 2012 3:24 pm
Location: Central NY


Return to General African Cichlid Discussion

Who is online

Users browsing this forum: No registered users and 1 guest