Aquarium Setup • finally got my 75!!

New to the world of cichlids? For discussion on how to set up new tanks, including placement, filtration, substrates, water, etc. No stocking discussions here.

Moderators: triscuit, fmueller

finally got my 75!!

Postby Clink51 » Sat Nov 26, 2011 5:10 pm

okay so i finally received my 75 gallon baby. 100 for filters heaters light and stand!

the catch is it doesnt have a top, no support braces and it used to be a turtle tank that died of unknown causes 5 years ago (according to the sellers).

So now i need to clean it and boy do i need help. What can i use to clean the inside, the silicon edges, the outside and the plastic top. Also is a support in the middle necessary? what can i use as a top for the tank? Theres also some white stains on top, kind of look like salt but not sure, how can i clean that off?

please help guys
10G - EMPTY
10G - EMPTY
29G - x8 Zebra Danios, Multi Colony (15 -/+ 2)
75G - x13 Cyp. Leptosoma (Utinta), x3 Alto. Comp, x6 Neo. Leleupi (Orange), x4 Tanganicodus Irsacae, x1 Albino Bristlenose
Clink51
 
Joined: Thu Aug 04, 2011 3:55 pm
Location: Queens, NY

Share On:

Share on Facebook Facebook Share on Twitter Twitter

Postby Im tanked » Sat Nov 26, 2011 5:15 pm

I just cleaned mine with a water / vinager solution, 3 parts water.....and a soft scrubbie. Turned out beautiful !
Im tanked
 
Joined: Tue Sep 27, 2011 2:15 am
Location: UTAH

Postby Clink51 » Sat Nov 26, 2011 5:17 pm

i never understood the x parts this w/ x parts that. does that mean 3 cups of water 1 cup of vinegar?
10G - EMPTY
10G - EMPTY
29G - x8 Zebra Danios, Multi Colony (15 -/+ 2)
75G - x13 Cyp. Leptosoma (Utinta), x3 Alto. Comp, x6 Neo. Leleupi (Orange), x4 Tanganicodus Irsacae, x1 Albino Bristlenose
Clink51
 
Joined: Thu Aug 04, 2011 3:55 pm
Location: Queens, NY

Postby livingroomdiver » Sat Nov 26, 2011 5:30 pm

exactly. It could be cups or gallons or anything else, as long as you use the same measure for both.
-55 Gallon w/ 20 Gallon sump-
2 - Herotilapia Multispinosa
1 - Thorichthys Maculipinnis
5 - Brilliant Rasbora
1 - Clown Plecostomus
1 - Rubber Lip Pleco
livingroomdiver
 
Joined: Sun Oct 09, 2011 9:14 pm
Location: Bellingham, WA

Postby Clink51 » Sat Nov 26, 2011 5:41 pm

what kinda of vinegar should i use?
10G - EMPTY
10G - EMPTY
29G - x8 Zebra Danios, Multi Colony (15 -/+ 2)
75G - x13 Cyp. Leptosoma (Utinta), x3 Alto. Comp, x6 Neo. Leleupi (Orange), x4 Tanganicodus Irsacae, x1 Albino Bristlenose
Clink51
 
Joined: Thu Aug 04, 2011 3:55 pm
Location: Queens, NY

Postby 13razorbackfan » Sat Nov 26, 2011 5:57 pm

Does it look like the center brace had been cut off? If so then you probably need to find a way to add one back.
User avatar
13razorbackfan
 
Joined: Wed Sep 28, 2011 12:19 am
Location: Arkansas

Postby skurj » Sat Nov 26, 2011 5:59 pm

plain old white/clear vinegar

Did it once have a brace that is now broken or it just doesn't have one?

for a top, you can get glass tops, might need 2 of them 24" long from any aquarium store.
User avatar
skurj
 
Joined: Sun Oct 30, 2011 8:36 am
Location: Oshawa, ON

Postby Clink51 » Sat Nov 26, 2011 6:28 pm

honostly,, it looks like it never even had one. is it really needed?
10G - EMPTY
10G - EMPTY
29G - x8 Zebra Danios, Multi Colony (15 -/+ 2)
75G - x13 Cyp. Leptosoma (Utinta), x3 Alto. Comp, x6 Neo. Leleupi (Orange), x4 Tanganicodus Irsacae, x1 Albino Bristlenose
Clink51
 
Joined: Thu Aug 04, 2011 3:55 pm
Location: Queens, NY

Postby 13razorbackfan » Sat Nov 26, 2011 7:15 pm

Clink51 wrote:honostly,, it looks like it never even had one. is it really needed?
If it was designed as an a aquarium to hold water and it looks like it never had a brace then you are probably good to go. Good luck.
User avatar
13razorbackfan
 
Joined: Wed Sep 28, 2011 12:19 am
Location: Arkansas


Return to Aquarium Setup

Who is online

Users browsing this forum: No registered users and 9 guests